Buscar artículos en cambiatealinux.com


¿ Eres desarrollador ? PHP, MySql, postgreSQL, ... " Visita https://www.netveloper.com encontrarás trucos, tutoriales y ayuda sobre programación.

Arranque lento de linux con el mensaje a start job is running for dev-disk-by


Por Alex el 06/08/2016 ( actualizado el 22/09/2021 ) , Comentarios: 4

Comparte este artículo:      

Pues esto es lo que me ha pasado hace poco, después de reinstalar un ubuntu, en la partición de Linux Mint tardaba mucho en arrancar y daba el mensaje a start job is running for dev-disk-by. Y esto no es mas que ha cambiado el UUID de alguna partición.


Al arrancar sale el siguiente error:

Mensaje de error al arrancar

Si no veis el mensaje de error que solo os sale el logo pulsa la tecla ESC y desaparece le logo y aparece el error.

Este error pasa porque alguna partición que tenéis definida en el fichero /etc/fstab ha cambiado de UUID

Ahora miraremos el UUID de que disco falla, vamos a mirar los UUID de los discos o particiones que tenemos ejecutando el siguiente comando:

sudo blkid


Y seguidamente miramos el fichero /etc/fstab para ver lo que tenemos en el fichero de arranque:

cat /etc/fstab


UUID de las particiones del disco

Como podéis ver en la imagen la partición de swap ha cambiado de UUID y eso es lo que hace que arranque lento el sistema.

Editamos el fichero fstab con el vim o en nano

sudo vim /etc/fstab


Y cambiamos el UUID por el nuevo

Fichero fstab

Y reiniciamos, con esto ya no deberia ir lento el arranque sino como siempre.

Y esto es todo amigos!!
Gracias por seguirme y leerme, espero que les haya ayudado
Saludos
Alex.



Si te ha gustado el artículo compartelo en:      


Publicidad


Añadir un comentarios:

Nombre:
Email: (no se publica el email)

avatar

Canduterio 13/11/2021 12:01:14

Gracias, me sirvió. Tenía miedo por si fastidiaba el arranque (así que hice una copia de la máquina virtual); pero no hubo ningún problema. Que Dios te bendiga con muchos hijos buenos y trabajadores para pagar las pensiones que está el futuro fatal.

avatar

Adrian 11/10/2021 17:07:11

Gracias, me ayudaste.

avatar

Alex 22/09/2021 06:34:32

Funcionó! Gracias!
Había eliminado una partición NTFS y no actualicé el FSTAB, demoraba 1min 30 seg en arrancar, ahora solo 12 seg!

avatar

Pablo 07/06/2021 10:11:23

En mi caso había agregado al fstab a la partición del USB de instalación
y en cada arranque que no estaba me penalizaba con 1:30 de espera
Lo comenté, y funcionó,
gracias

avatar

Paul 01/04/2021 07:59:12

Maravilloso, funciona perfecto

avatar

Jonathan Guisao Sucerquia 10/08/2020 09:35:20

Muchas gracias. Estaba preocupado, pero se arregló de una.

avatar

Pitu 03/08/2020 09:26:54

Me funcionó a la primera, muchisimas gracias cracks!

avatar

Carlos Nunes 02/03/2020 18:13:01

Hola, buen articulo, tengo ese problema hoy lo pruebo y os digo alguna cosa,
de igual forma ya los sigo por gratificación.
Buen trabajo.

avatar

Morpheus 17/12/2019 09:48:24

Solo para agradecerte por el articulo.
En mi caso el problema era que la particion swap se habia quedado sin uuid pero con gparted click derecho y asignar uuid logre continuar con tu proceso y resolver el problema muchas gracias.

avatar

Hector Zúñiga 18/08/2019 09:31:31

Muchas gracias por tu ayuda!!..... si no fuera por ti, hubiera tirado el pc al water

Saludos

avatar

Ricardo Gonzalez 29/07/2017 18:17:00

Gracias por compartir generosamente tu gran conocimiento.
Me funcionó muy bien, y me resolvió el problema.
Saludos.





Publicidad



RECOMENDADOS


LOS MAS LEÍDOS


CATEGORÍAS
ARCHIVO


COMENTARIOS